A fix has been implemented and we are monitoring the results.
Posted Jan 24, 2025 - 13:37 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 23, 2025 - 15:22 CET
Investigating
We are experiencing problems with merchants missing information about their settlement payouts in Merchant portal. We are working on resolving the issue, and we will send an update when we have new information.