Degraded service for payment processing in Finland region for some users

Incident Report for Vipps MobilePay

Resolved

This incident has been resolved.
Posted Feb 20, 2024 - 13:01 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2024 - 12:53 CET

Investigating

We are experiencing problems with card payments in Finland region, and this affects some users. We are working on resolving the issue, and will send an update as soon as we have new information.
Posted Feb 20, 2024 - 12:37 CET
This incident affected: Finland (Payment Processing).