A fix has been implemented and we are monitoring the results.
Posted Nov 23, 2024 - 17:12 CET
Update
Due to updates at an external vendor, signing and new order placement in Merchant Portal will be unavailable from 22 November at 15:30 until Saturday, 23 November at 20:00.
Posted Nov 22, 2024 - 21:36 CET
Investigating
Agreement signing and new order placement in the merchant portal are currently impacted due to an external issue.